// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Let's start(.*[\r\n])*.*my friend\.").unwrap();
let string = "Let's start! ... blah, blah, blah...
How much longer? It's joe's place, isn't it?
This is the end, my friend.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}