package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+[A-Z]\w+)`)
var str = `MiguelGarcia
JohnDoe
Jan Smit
Jansen
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}