use strict;
my $str = 'MiguelGarcia
JohnDoe
Jan Smit
Jansen
';
my $regex = qr/(\w+[A-Z]\w+)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";