$re = '/Shown prices, for exchange of ocassions are only for indication\.(*SKIP)(*F)|\b(exchange|occasion|second hand)\b/i';
$str = 'Shown prices, for exchange of ocassions are only for indication. In exchange of this';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);