re = /Shown prices, for exchange of ocassions are only for indication\.(*SKIP)(*F)|\b(exchange|occasion|second hand)\b/i
str = 'Shown prices, for exchange of ocassions are only for indication. In exchange of this'
# Print the match result
str.match(re) do |match|
puts match.to_s
end