const regex = /(?:(?!\w)|\b(?=\w))(?:\(not working text|working text)(?:(?<=\w)\b|(?<!\w))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?!\\w)|\\b(?=\\w))(?:\\(not working text|working text)(?:(?<=\\w)\\b|(?<!\\w))', 'g')
const str = `working text and (not working text
working text and(not working text`;
const subst = `<mark>$&</mark>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);