import re
regex = re.compile(r"(?:(?!\w)|\b(?=\w))(?:\(not working text|working text)(?:(?<=\w)\b|(?<!\w))")
test_str = ("working text and (not working text\n"
"working text and(not working text")
subst = "<mark>$&</mark>"
result = regex.sub(subst, test_str)
if result:
print(result)