#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)>(.*?)\s*(\n|\[([A-Z]+)\]?\n)"
Local $sString = ">BnaCnng71140D [BRANA]" & @CRLF & _
"MTSSFKLSDLEEVTTNAEKIQNDLLKEILTLNAKTEYLRQFLHGSSDKTFFKKHVPVVSYEDMKPYIERVADGEPSEIIS" & @CRLF & _
"GGPITKFLRRYSF" & @CRLF & _
"" & @CRLF & _
">Cadbaweo98702.t [THATH]" & @CRLF & _
"MTSSFKLSDLEEVTTNAEKIQNDLLKEILTLNAKTEYLRQFLHGSSDKTFFKKHVPVVSYEDMKPYIERVADGEPSEIIS" & @CRLF & _
"GGPITKFLRRYSF" & @CRLF & _
"" & @CRLF & _
">Cadbaweo98702.t" & @CRLF & _
"MTSSFKLSDLEEVTTNAEKIQNDLLKEILTLNAKTEYLRQFLHGSSDKTFFKKHVPVVSYEDMKPYIERVADGEPSEIIS" & @CRLF & _
"GGPITKFLRRYSF" & @CRLF & _
"" & @CRLF & _
">Cadbaweo98702.t [XXXX]" & @CRLF & _
"MTSSFKLSDLEEVTTNAEKIQNDLLKEILTLNAKTEYLRQFLHGSSDKTFFKKHVPVVSYEDMKPYIERVADGEPSEIIS" & @CRLF & _
"GGPITKFLRRYSF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")