import re
regex = re.compile(r">(.*?)\s*(\n|\[([A-Z]+)\]?\n)", flags=re.MULTILINE)
test_str = (">BnaCnng71140D [BRANA]\n"
"MTSSFKLSDLEEVTTNAEKIQNDLLKEILTLNAKTEYLRQFLHGSSDKTFFKKHVPVVSYEDMKPYIERVADGEPSEIIS\n"
"GGPITKFLRRYSF\n\n"
">Cadbaweo98702.t [THATH]\n"
"MTSSFKLSDLEEVTTNAEKIQNDLLKEILTLNAKTEYLRQFLHGSSDKTFFKKHVPVVSYEDMKPYIERVADGEPSEIIS\n"
"GGPITKFLRRYSF\n\n"
">Cadbaweo98702.t\n"
"MTSSFKLSDLEEVTTNAEKIQNDLLKEILTLNAKTEYLRQFLHGSSDKTFFKKHVPVVSYEDMKPYIERVADGEPSEIIS\n"
"GGPITKFLRRYSF\n\n"
">Cadbaweo98702.t [XXXX]\n"
"MTSSFKLSDLEEVTTNAEKIQNDLLKEILTLNAKTEYLRQFLHGSSDKTFFKKHVPVVSYEDMKPYIERVADGEPSEIIS\n"
"GGPITKFLRRYSF")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")