import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{8}";
final String string = "Restoration Coder: Mr. Vivek Patel 488.90 488.90\n"
+ "Attn: Mr. Matt Lomano (WO# 24107788)\n"
+ "0le Asphalt Repairs (Traffic ControltRemoval ofSpoilsfiSawcutting)\n"
+ "80 W est. Beaver Creek (Richmond Hill)\n"
+ "Restoration Coder: Mr. Vivek Patel 196.76 196.76\n"
+ "Attn: Mr. Matt. Lomano (WO# 23407489)\n"
+ "cfo Sod Repairs\n"
+ "270 Avro Rd (Maple)\n"
+ "Restoration Coder: Mr. Vivelc Patel 282.60 28260\n"
+ "Attn: Mr. Matt Lomano (W03? 23713545)\n"
+ "cfo Sod Repairs (Removal of Spoilszopsoil/Seeding)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}