#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[a-zA-Z]*\d{5,}[a-zA-Z]*\b"
Local $sString = "Corresponding to\n"" & @CRLF & _
"... "1 102742238 CN A 2012-10-17 ZTE USA Inc. US20130094411A1\n"" & @CRLF & _
"... "3 20150318972 2015-11-05 Zhang et al.\n"" & @CRLF & _
"... "2 20130128860 2013-05-23 Zhang\n"" & @CRLF & _
"... "1 20130094411 2013-04-18 Zhang\n"" & @CRLF & _
"... "EFS Web 2.1.17\n"" & @CRLF & _
"... "Examiner Signature Date Considered\n"" & @CRLF & _
"... "3rd Generation Partnership Project; Technical Specification Group Radio Access Network; Evolved Universal\n"" & @CRLF & _
"... "1 Terrestrial Radio Access (E-UTRA); Physical channels and modulation (Release 12), 3GPP TS 36.211 V12.7.0\n"" & @CRLF & _
"... "fONAR_ NAN 12R nanac\n"" & @CRLF & _
"... "vs Corresponding to\n"" & @CRLF & _
"... "4 2014110837 WO Al 2014-07-24 Fujitsu Ltd. et al. US20150318972A1\n"" & @CRLF & _
"... "3 2014107012 WO Al 2014-07-10 LG Electronics Inc.\n"" & @CRLF & _
"... "; Corresponding to\n"" & @CRLF & _
"... "2 103120006 CN A 2013-05-22 ZTE Corporation US20130128860A1\n"" & @CRLF & _
"... "EFS Web 2.1.17\n"" & @CRLF & _
"... "| |\n"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")