const regex = /\b[a-zA-Z]*\d{5,}[a-zA-Z]*\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[a-zA-Z]*\\d{5,}[a-zA-Z]*\\b', 'gm')
const str = `Corresponding to\\n"
... "1 102742238 CN A 2012-10-17 ZTE USA Inc. US20130094411A1\\n"
... "3 20150318972 2015-11-05 Zhang et al.\\n"
... "2 20130128860 2013-05-23 Zhang\\n"
... "1 20130094411 2013-04-18 Zhang\\n"
... "EFS Web 2.1.17\\n"
... "Examiner Signature Date Considered\\n"
... "3rd Generation Partnership Project; Technical Specification Group Radio Access Network; Evolved Universal\\n"
... "1 Terrestrial Radio Access (E-UTRA); Physical channels and modulation (Release 12), 3GPP TS 36.211 V12.7.0\\n"
... "fONAR_ NAN 12R nanac\\n"
... "vs Corresponding to\\n"
... "4 2014110837 WO Al 2014-07-24 Fujitsu Ltd. et al. US20150318972A1\\n"
... "3 2014107012 WO Al 2014-07-10 LG Electronics Inc.\\n"
... "; Corresponding to\\n"
... "2 103120006 CN A 2013-05-22 ZTE Corporation US20130128860A1\\n"
... "EFS Web 2.1.17\\n"
... "| |\\n"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}