$re = '/(?<=\s)(\w+=(?:"(?:(?<=\\\\)"|[^"])+"|[\S]+))/m';
$str = 'update DIFFICULTY=1 DESCRIPTION="some long teste= on description" ASD=3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);