re = /(?<=\s)(\w+=(?:"(?:(?<=\\)"|[^"])+"|[\S]+))/m
str = 'update DIFFICULTY=1 DESCRIPTION="some long teste= on description" ASD=3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end