const regex = /^([^_]*)_Batch_summary_(\d+)_SS11_(\d+)\.log$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^_]*)_Batch_summary_(\\d+)_SS11_(\\d+)\\.log$', 'gm')
const str = `Daily_Batch_summary_001_SS11_20181107165728.log
Monthly_Batch_summary_002_SS11_20181107165811.log`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}