$re = '/^([^_]*)_Batch_summary_(\d+)_SS11_(\d+)\.log$/m';
$str = 'Daily_Batch_summary_001_SS11_20181107165728.log
Monthly_Batch_summary_002_SS11_20181107165811.log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);