$re = '/^(\w+,\s\w+\s\w+)$|^(\w+,\s\w+\s\w+\.)$|^(\w+,\s\w+)$/m';
$str = 'Bob, Dylan Tina
Bob, Dylan T.
Bob, Dylan';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);