re = /^(\w+,\s\w+\s\w+)$|^(\w+,\s\w+\s\w+\.)$|^(\w+,\s\w+)$/m
str = 'Bob, Dylan Tina
Bob, Dylan T.
Bob, Dylan'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end