import re
regex = re.compile(r"<SW-VARIABLE>\s*<SHORT-NAME>(?P<sn>[^<]*?)</SHORT-NAME>.*?<SW-ARRAYSIZE>\s*<VF>(?P<vf>[^<]*?)</VF>\s*</SW-ARRAYSIZE>.*?<(?:/(?!<SW-VARIABLE>)[^/]*?)SW-VARIABLE>", flags=re.DOTALL | re.MULTILINE)
test_str = (" <SW-VARIABLE>\n"
" <SHORT-NAME>abc</SHORT-NAME>\n"
" <CATEGORY>VALUE</CATEGORY>\n"
" <SW-ARRAYSIZE>\n"
" <VF>4</VF>\n"
" </SW-ARRAYSIZE>\n"
" <SW-DATA-DEF-PROPS>\n"
" cde\n"
" </SW-DATA-DEF-PROPS>\n"
" </SW-VARIABLE>\n\n"
" <SW-VARIABLE>\n"
" <SHORT-NAME>def</SHORT-NAME>\n"
" <CATEGORY>VALUE</CATEGORY>\n"
" <SW-ARRAYSIZE>\n"
" <VF>8</VF>\n"
" </SW-ARRAYSIZE>\n"
" <SW-DATA-DEF-PROPS>\n"
" <HELLO>dsfadsf </HELLO>\n"
" <NO>itis</NO>\n"
" </SW-DATA-DEF-PROPS>\n"
" </SW-VARIABLE>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")