re = /<SW-VARIABLE>\s*<SHORT-NAME>(?P<sn>[^<]*?)<\/SHORT-NAME>.*?<SW-ARRAYSIZE>\s*<VF>(?P<vf>[^<]*?)<\/VF>\s*<\/SW-ARRAYSIZE>.*?<(?:\/(?!<SW-VARIABLE>)[^\/]*?)SW-VARIABLE>/m
str = ' <SW-VARIABLE>
<SHORT-NAME>abc</SHORT-NAME>
<CATEGORY>VALUE</CATEGORY>
<SW-ARRAYSIZE>
<VF>4</VF>
</SW-ARRAYSIZE>
<SW-DATA-DEF-PROPS>
cde
</SW-DATA-DEF-PROPS>
</SW-VARIABLE>
<SW-VARIABLE>
<SHORT-NAME>def</SHORT-NAME>
<CATEGORY>VALUE</CATEGORY>
<SW-ARRAYSIZE>
<VF>8</VF>
</SW-ARRAYSIZE>
<SW-DATA-DEF-PROPS>
<HELLO>dsfadsf </HELLO>
<NO>itis</NO>
</SW-DATA-DEF-PROPS>
</SW-VARIABLE>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end