package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ *[^ ]* *$`)
var str = `MCWG
23-11-2011 O
DOP
01-06-1989 B-NUM
BG O
Name O`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}