$re = '/^ *[^ ]* *$/m';
$str = 'MCWG
23-11-2011 O
DOP
01-06-1989 B-NUM
BG O
Name O';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);