#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b((?:href|src)=)(?!\/\/example\.com)(["']?)([^"']+)\2"
Local $sString = "<html>" & @CRLF & _
"<link rel="stylesheet" href="/thing.css">" & @CRLF & _
"" & @CRLF & _
"<body>" & @CRLF & _
" <script src="/nothing.js"></script>" & @CRLF & _
" <link rel="stylesheet" href="/styles.css">" & @CRLF & _
" <a href='#a_hash'>A link</a>" & @CRLF & _
"</body>" & @CRLF & _
"" & @CRLF & _
"</html>"
Local $sSubst = "$1$2//example.com$3$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)