const regex = /\b((?:href|src)=)(?!\/\/example\.com)(["']?)([^"']+)\2/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b((?:href|src)=)(?!\\\/\\\/example\\.com)(["\']?)([^"\']+)\\2', 'gm')
const str = `<html>
<link rel="stylesheet" href="/thing.css">
<body>
<script src="/nothing.js"></script>
<link rel="stylesheet" href="/styles.css">
<a href='#a_hash'>A link</a>
</body>
</html>`;
const subst = `$1$2//example.com$3$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);