re = /(<dependency>\s+<groupId>)(.+)(<\/groupId>\s+<artifactId>)(.+)(<\/artifactId>\s+<version>)([^\$]+?)(<\/version>[\s\S]*?\s+<\/dependency>)/
str = ' <dependency>
<groupId>org.example.one</groupId>
<artifactId>example1</artifactId>
<version>1.2.3</version>
</dependency>
<dependency>
<groupId>org.example.two</groupId>
<artifactId>example2</artifactId>
<version>${example2.version}</version>
</dependency>
<dependency>
<groupId>org.example.three</groupId>
<artifactId>example3</artifactId>
<version>1.2.3</version>
<scope>test</scope>
</dependency>
<dependency>
<groupId>org.example.four</groupId>
<artifactId>example4</artifactId>
<version>${example4.version}</version>
<scope>test</scope>
</dependency>
<dependency>
<groupId>org.example.five</groupId>
<artifactId>example5</artifactId>
<version>1.2.3</version>
<scope>test</scope>
<exclusions>
<exclusion>
<artifactId>*</artifactId>
<groupId>*</groupId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>org.example.six</groupId>
<artifactId>example6</artifactId>
<version>${example6.version}</version>
<scope>test</scope>
<exclusions>
<exclusion>
<artifactId>*</artifactId>
<groupId>*</groupId>
</exclusion>
</exclusions>
</dependency>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end