package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]{4}-){4}`)
var str = `6244-5567-8912-3458-
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}