$re = '/([0-9]{4}-){4}/';
$str = '6244-5567-8912-3458-
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);