const regex = /(?<=\b[a-zA-Z]\d[a-zA-Z] \d[a-zA-Z]\d)\s+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\b[a-zA-Z]\\d[a-zA-Z] \\d[a-zA-Z]\\d)\\s+', 'gm')
const str = `160 Rue, Notre Dame N, Bureau 140, Sainte-Marie, G6E 3Z9 887 Chemin du Bord de l'Eau, Saint-Henri de Levis, G0R 3E0`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);