$re = '/(?<=\b[a-zA-Z]\d[a-zA-Z] \d[a-zA-Z]\d)\s+/m';
$str = '160 Rue, Notre Dame N, Bureau 140, Sainte-Marie, G6E 3Z9 887 Chemin du Bord de l\'Eau, Saint-Henri de Levis, G0R 3E0';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;