using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"izvlekaem-(\d+)-(\d+)";
string input = @"sluchainaya-stroka-izvlekaem-15-658-dalhse-idet-bred-18-56
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}