$re = '/^[^\W_]+(?:([^\s\da-z.)(])(?!.*\1)[^\W_]*)*$/mi';
$str = 'abc123
ACEEL$!0A101
Example*L%
a!bc!%3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);