re = /^[^\W_]+(?:([^\s\da-z.)(])(?!.*\1)[^\W_]*)*$/mi
str = 'abc123
ACEEL$!0A101
Example*L%
a!bc!%3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end