package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)meta name="description" content="([\w\s]+)"`)
var str = `<meta name="description" content="I want to get this description of this meta tag" />`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}