$re = '/meta name="description" content="([\w\s]+)"/m';
$str = '<meta name="description" content="I want to get this description of this meta tag" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);