// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)rfi (.*?) .*?(\((?:[^()]++|(?2))*\))").unwrap();
let string = "New RFI 087 (Concrete Beam at Planter)
New RFI 087 (Concrete (Beam) at Planter)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}