import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9a-zA-Z]{10}.*([A-Z\\s]{16,})\\\\n";
final String string = "\n\n\n"
+ "4nXQOweFyC\\x10HWANG SEAN SOJIN\\n\n"
+ "^[0-9a-zA-Z]{10}\\\\[0-9a-z]{3}([A-Z\\s]{3,})\\\\n\n\n"
+ "^[0-9a-zA-Z]{10}\\\\x10([A-Z\\s]{3,})\\\\n\n\n"
+ "^[0-9a-zA-Z]{10}\\\\x14([A-Z\\s]{3,})\\n\n\n"
+ "# 정의되어야 함\n\n"
+ "4nYBfE4dug\\x07GUO JIE\\n\n\n"
+ "4nYWf22CBO\\x08LI FULAN\\n\n\n\n"
+ "^[0-9a-zA-Z]{10}\\\\x08([A-Z\\s]{3,})\\\\n\n\n\n"
+ "4mfP1jNaF4\\x14광진실리콘(주)\\n\n\n\n"
+ "4nXckRULYB\\x0fCHANG LAI HSIEN\\n\n\n"
+ "0UN97Wa9oU\\t507030360A0130(\\x010\\x011\\x011\\x010\\x0202\\x011(\\x010(\\x010\\x01N\\x0b20년/20년\\x082021031860860\\x012\\x011\\x03B\\x011\\x01N\\x0820210318\\x0820210318\\x0820210318\\x132021-03-18 12:01:34\\x011\\x0fCHANG LAI HSIEN\\x132021-03-18 10:57:01\\x132021-03-18 10:57:14\\x02[메리츠화재] 모바일 전자서명 안내\\n\n\n"
+ "4nAjfKqh8i\\x0bQUAN CANXIE\\n\n\n"
+ "^[0-9a-zA-Z]{10}\\x0b(\\([가-힣].*)\\n\n"
+ "^[0-9a-zA-Z]{10}([A-Z가-힣\\s]{2,})\\\\n\n\n\n\n"
+ "4nXzVRFyIl\\tJIN GUANGMAN\\n\n\n\n"
+ "4nXzVRFyIl\\t김현수\\n\n\n"
+ "4nJcIVZHxD\\x0b(주)철마\\n\n"
+ "^[0-9a-zA-Z]{10}\\\\x0b(\\\\([가-힣].*)\\\\n\n"
+ "^[0-9a-zA-Z]{10}\\\\x0b(\\([가-힣].*)\\\\n\n\n\n\n\n"
+ "^[0-9a-zA-Z]{10}\\t([A-Z가-힣\\s]{2,})\\n\n\n\n\n"
+ "^[0-9a-zA-Z]{10}\\\\t([A-Z가-힣\\s]{2,})\\\\n\n\n"
+ "^[0-9a-zA-Z]{10}\\t([A-Z가-힣\\s]{2,})\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}