using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)\d{16}(?!\d)";
string input = @"1234567812345678
abcbb1234567812345678axaa
123123456781234567812121asaasa
____hbadchc()1234567812345678csdhcbs";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}