$re = '/[\w-]+\.sql/m';
$str = 'AAAAAAAA.BBBBBBBBBBB.sql
AAAAAAAA.BBBBB-CCCCCCC.sql
--a--.sql';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);