re = /[\w-]+\.sql/m
str = 'AAAAAAAA.BBBBBBBBBBB.sql
AAAAAAAA.BBBBB-CCCCCCC.sql
--a--.sql'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end