const regex = /(?<=\A(?:(?!Location:)(?s:.))*Location:.*?\().*?(?=\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\A(?:(?!Location:)(?s:.))*Location:.*?\\().*?(?=\\))', 'g')
const str = `--batchresponse_bla_bla_bla_\\r\\n--changesetresponse__bla_bla_bla_\\r\\nLocation: https://site.ru/CRM/api/data/v9.0/gm_preorders(a341eb4e-2fdf-eb11-a30b-ac1f6b465e3b)\\r\\nOData-EntityId: https://site.ru/CRM/api/data/v9.0/gm_preorders(a341eb4e-2fdf-eb11-a30b-ac1f6b465e3b)\\r\\n_bla_bla_bla_\\r\\n--changesetresponse__bla_bla_bla_Location: https://site.ru/CRM/api/data/v9.0/gm_preorders(a841eb4e-2fdf-eb11-a30b-ac1f6b465e3b)\\r\\nOData-EntityId: https://site.ru/CRM/api/data/v9.0/gm_preorders(a841eb4e-2fdf-eb11-a30b-ac1f6b465e3b)\\r\\n_bla_bla_bla_\\r\\n--changesetresponse_n_bla_bla_bla_\\r\\nLocation: https://site.ru/CRM/api/data/v9.0/gm_preorders(74748d08-2ee6-eb11-a30b-ac1f6b465e3b)\\r\\nOData-EntityId: https://site.ru/CRM/api/data/v9.0/gm_preorders(74748d08-2ee6-eb11-a30b-ac1f6b465e3b)\\r\\nn_bla_bla_bla_\\r\\n--changesetresponse_etc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}