re = /(?<=\A(?:(?!Location:)(?s:.))*Location:.*?\().*?(?=\))/
str = '--batchresponse_bla_bla_bla_\\r\\n--changesetresponse__bla_bla_bla_\\r\\nLocation: https://site.ru/CRM/api/data/v9.0/gm_preorders(a341eb4e-2fdf-eb11-a30b-ac1f6b465e3b)\\r\\nOData-EntityId: https://site.ru/CRM/api/data/v9.0/gm_preorders(a341eb4e-2fdf-eb11-a30b-ac1f6b465e3b)\\r\\n_bla_bla_bla_\\r\\n--changesetresponse__bla_bla_bla_Location: https://site.ru/CRM/api/data/v9.0/gm_preorders(a841eb4e-2fdf-eb11-a30b-ac1f6b465e3b)\\r\\nOData-EntityId: https://site.ru/CRM/api/data/v9.0/gm_preorders(a841eb4e-2fdf-eb11-a30b-ac1f6b465e3b)\\r\\n_bla_bla_bla_\\r\\n--changesetresponse_n_bla_bla_bla_\\r\\nLocation: https://site.ru/CRM/api/data/v9.0/gm_preorders(74748d08-2ee6-eb11-a30b-ac1f6b465e3b)\\r\\nOData-EntityId: https://site.ru/CRM/api/data/v9.0/gm_preorders(74748d08-2ee6-eb11-a30b-ac1f6b465e3b)\\r\\nn_bla_bla_bla_\\r\\n--changesetresponse_etc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end