const regex = /\b(?!lv\b)\w+\b(?=(?:\s+lv)?\s+d(?:[iy]a|i)stolic d[yi]sfunction)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!lv\\b)\\w+\\b(?=(?:\\s+lv)?\\s+d(?:[iy]a|i)stolic d[yi]sfunction)', 'gmi')
const str = `*AVR(1380),redo AVR (1396)due to AV prosthesis malfunction -Normal LV size with preserved systolic function(GEF= 50-55%)severe hypertrophy in apical segments maximom thickness=1.6cm with sparing of posterior wall, echo feature is mostly compatible with apical HCM-Mild LV diastolic dysfunction(Grade I)-Normal RV size with mild systolic dysfunction -Mild biatrial enlargemen (LAVI=40cc/m2 ,RAVI=33cc/m2)-Normal MVLs ; No MS;Mild to moderate MR-Mechanical prosthesis AV with good hemodynamic study (MG=6mmHg ,PG=11mmHg , AVACCT=63)No paravalvular leakage ;dilated ascending aorta=3.9cm ,(No visible dissection flap in ascending) -Normal PVLs ;No PS;Mild PI;Mean PAP=22mmHg-Normal TVLs ;No TS;Mild TR-Top Normal PAP-Normal IVC size and collapse-No pericardial effusion-IAS redundant
-HOCM type III with significant resting LVOT obstruction(PPG=100 mmHg)-Normal LV size with good systolic function(EF=60%)-Mild diastolic dysfunction(grade I)-Normal RV size and systolic function-Severe SAM with moderate eccentric MR(ROA=0.25 cm2)-Mild TR-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}