import Foundation
let pattern = #"\b(?!lv\b)\w+\b(?=(?:\s+lv)?\s+d(?:[iy]a|i)stolic d[yi]sfunction)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
*AVR(1380),redo AVR (1396)due to AV prosthesis malfunction -Normal LV size with preserved systolic function(GEF= 50-55%)severe hypertrophy in apical segments maximom thickness=1.6cm with sparing of posterior wall, echo feature is mostly compatible with apical HCM-Mild LV diastolic dysfunction(Grade I)-Normal RV size with mild systolic dysfunction -Mild biatrial enlargemen (LAVI=40cc/m2 ,RAVI=33cc/m2)-Normal MVLs ; No MS;Mild to moderate MR-Mechanical prosthesis AV with good hemodynamic study (MG=6mmHg ,PG=11mmHg , AVACCT=63)No paravalvular leakage ;dilated ascending aorta=3.9cm ,(No visible dissection flap in ascending) -Normal PVLs ;No PS;Mild PI;Mean PAP=22mmHg-Normal TVLs ;No TS;Mild TR-Top Normal PAP-Normal IVC size and collapse-No pericardial effusion-IAS redundant
-HOCM type III with significant resting LVOT obstruction(PPG=100 mmHg)-Normal LV size with good systolic function(EF=60%)-Mild diastolic dysfunction(grade I)-Normal RV size and systolic function-Severe SAM with moderate eccentric MR(ROA=0.25 cm2)-Mild TR-
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)