# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<link.*(href=\".*?\/abcd\.css\")[^>]*>"
test_str = ("<html data-reactroot=\"\" class=\"gr__localhost\"><head><link rel=\"stylesheet\" href=\"/dist/qwefqwefqwef.css\" /><link rel=\"stylesheet\" href=\"/dist/abcd.css\" /><meta charset=\"utf-8\"><meta name=\"viewport\" content=\"width=device-width,initial-scale=1,maximum-scale=1,minimum-scale=1,user-scalable=no\"><script type=\"text/javascript\" async=\"\" src=\"https://www.google-analytics.com/analytics.js\"></script><script>window.g_useSSR=true;\n"
" window.g_initialData = {};</script><script>window.routerBase = \"/\";</script><link rel=\"stylesheet\" href=\"<script src=\" dist=\"\" umi.4c8c3b87.js\"vendors.f848cc19.chunk.css\"=\"\"><link")
matches = re.search(regex, test_str, re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.