re = /<link.*(href=".*?\/abcd\.css")[^>]*>/i
str = '<html data-reactroot="" class="gr__localhost"><head><link rel="stylesheet" href="/dist/qwefqwefqwef.css" /><link rel="stylesheet" href="/dist/abcd.css" /><meta charset="utf-8"><meta name="viewport" content="width=device-width,initial-scale=1,maximum-scale=1,minimum-scale=1,user-scalable=no"><script type="text/javascript" async="" src="https://www.google-analytics.com/analytics.js"></script><script>window.g_useSSR=true;
window.g_initialData = {};</script><script>window.routerBase = "/";</script><link rel="stylesheet" href="<script src=" dist="" umi.4c8c3b87.js"vendors.f848cc19.chunk.css"=""><link'
# Print the match result
str.match(re) do |match|
puts match.to_s
end