import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?![1234]px)(\\d*)(\\d)(?:\\.(\\d+))?px\\b";
final String string = "font-size: 10px;\n"
+ "border: 0px;\n"
+ "margin-top: 4px; // dont touch\n"
+ "margin-bottom: 12px;\n"
+ "margin-right: 50%;\n"
+ "margin-left: -12px;\n"
+ "padding-left: 120px;\n"
+ "padding-right: 8px;\n"
+ "border-radius: calc(50% - 1px); // dont touch\n"
+ "grid-template-columns: 1fr 44px 1fr;\n"
+ "margin-top: 36.4px;\n"
+ "border-width: 10.5px;\n"
+ "border-width: .3px; // dont touch\n"
+ "border-width: .6px; // dont touch\n"
+ "border-width: 3.3px; // dont touch\n"
+ "border-width: 6.6px;\n"
+ "margin-left: -1px; // dont touch";
final String subst = "$1.$2$3rem";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}