const regex = /\b(?![1234]px)(\d*)(\d)(?:\.(\d+))?px\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?![1234]px)(\\d*)(\\d)(?:\\.(\\d+))?px\\b', 'gm')
const str = `font-size: 10px;
border: 0px;
margin-top: 4px; // dont touch
margin-bottom: 12px;
margin-right: 50%;
margin-left: -12px;
padding-left: 120px;
padding-right: 8px;
border-radius: calc(50% - 1px); // dont touch
grid-template-columns: 1fr 44px 1fr;
margin-top: 36.4px;
border-width: 10.5px;
border-width: .3px; // dont touch
border-width: .6px; // dont touch
border-width: 3.3px; // dont touch
border-width: 6.6px;
margin-left: -1px; // dont touch`;
const subst = `$1.$2$3rem`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);