const regex = /(?<=i_)(?:.*(?=_)|.*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=i_)(?:.*(?=_)|.*$)', 'gm')
const str = `i_123_Mobile
i_123_abc_Mobile
i_123aa_abcdaeedg_Desktop
i_abc123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}