re = /(?<=i_)(?:.*(?=_)|.*$)/m
str = 'i_123_Mobile
i_123_abc_Mobile
i_123aa_abcdaeedg_Desktop
i_abc123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end