import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#(?!:[\\w]+)(?=([\\w\\d\\[\\]\\,\\*\\=\\>\\.\\s]*[\\{\\,\\[]+))";
final String string = "div#xyz, #xyz, div#xyz[id='xyz'],\n"
+ " .def>#xyz, .def>div#xyz, .def>#xyz,\n"
+ " .def>div#xyz[id=*]{\n"
+ " color:#ee2ee2;\n"
+ "}\n\n\n"
+ "@media (min-width: 30em) and (orientation: landscape) \n"
+ "{\n"
+ " .abc{\n"
+ " background-color :#FFFFFF;\n"
+ " border-color:1px solid #eee ;\n"
+ " }\n\n"
+ " .def>#xyz, .def #xyz, .def>#xyz{border-color:1px solid #ddd;}\n"
+ "}";
final String subst = ".";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}